Commit 9870271f authored by Reinhold Kainhofer's avatar Reinhold Kainhofer

V1.3.8: Add debug messages to the update system (disabled by default); Remove...

V1.3.8: Add debug messages to the update system (disabled by default); Remove debug code that causes problems in strict mode
parent 43c09d2e
BASE=ordernumbers
PLATTFORM=woocommerce
VENDOR=opentools
VERSION=1.3.7debug1
VERSION=1.3.8
DIR = $(shell pwd)
SVNDIR=wordpress-plugin-svn
......
......@@ -23,7 +23,7 @@ class OpenToolsPluginUpdateChecker extends PluginUpdateChecker_2_1 {
public function __construct($metadataUrl, $pluginFile, $slug = '', $checkPeriod = 12, $optionName = '', $muPluginFile = '')
{
parent::__construct($metadataUrl, $pluginFile, $slug, $checkPeriod, $optionName, $muPluginFile);
$this->debugMode = TRUE;
// $this->debugMode = TRUE;
$this->installOTHooks();
}
public function declareCredentials($credential_def) {
......@@ -129,15 +129,6 @@ class OpenToolsPluginUpdateChecker extends PluginUpdateChecker_2_1 {
return;
}
$json['showCredentials'] = $showCredentials;
$json['issetSLUG'] = isset($_REQUEST['slug']);
$json['SLUGmatches'] = $_REQUEST['slug'] == $this->slug;
$json['userCanUpdatePlugins'] = current_user_can('update_plugins');
$json['checkAjax'] = check_ajax_referer('otup_enter_update_credentials');
$json['NotEmptyCredVars'] = !empty($this->credvars);
$json['IsNetworkAdmin'] = is_network_admin();
$json['isMultisite'] = is_multisite();
$showCredentials = isset($_REQUEST['slug'])
&& $_REQUEST['slug'] == $this->slug
&& current_user_can('update_plugins')
......
......@@ -4,7 +4,7 @@ Contributors: opentools
Tags: WooCommerce, Order numbers, orders
Requires at least: 4.0
Tested up to: 4.7
Stable tag: 1.3.7
Stable tag: 1.3.8
License: GPLv3 or later
License URI: http://www.gnu.org/licenses/gpl.html
......@@ -78,6 +78,9 @@ The Advanced Ordernumbers for WooCommerce plugin supports some invoicing plugins
== Changelog ==
= 1.3.8 =
* Add debug messages to the update system (disabled by default)
= 1.3.7 =
* Add support for PayPal payment method
* Add variables:
......
......@@ -3,7 +3,7 @@
* Plugin Name: Woocommerce Advanced Ordernumbers
* Plugin URI: http://open-tools.net/woocommerce/advanced-ordernumbers-for-woocommerce.html
* Description: Lets the user freely configure the order numbers in WooCommerce.
* Version: 1.3.7debug1
* Version: 1.3.8
* Author: Open Tools
* Author URI: http://open-tools.net
* Text Domain: woocommerce-advanced-ordernumbers
......
......@@ -3,7 +3,7 @@
* Plugin Name: WooCommerce Basic Ordernumbers
* Plugin URI: http://open-tools.net/woocommerce/advanced-ordernumbers-for-woocommerce.html
* Description: Configure WooCommerce ordernumbers to have a running counter and arbitrary, fixed text (prefix / postfix).
* Version: 1.3.7debug
* Version: 1.3.8
* Author: Open Tools
* Author URI: http://open-tools.net
* Text Domain: woocommerce-advanced-ordernumbers
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment